mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


Old Motifator threads are available in the Archive.

Viewing topic "S90XS not finishing to boot up"

Posted on: October 17, 2021 @ 03:18 AM
Total Posts:  5
Joined  10-17-2021
status: Newcomer

Hello Motifators,

Looking for some help here.
I have an S90XS that wasn’t booting correctly, half of the buttons were blinking, but none of the buttons, sliders and the dial were working.

Following some recommendations in other threads here, I proceeded to update the firmware to 1.06, the latest available on the internet, or at least the latest I could found (I know of a friend who bought a used S90XS and the firmware said 1.07, anyways ...)

The update seems that went fine, as shown in the attached pic.

When I power cycled the S90XS it was looping into the “Auto Factory Reset”, thus, I went into the menu to turn that off, however a message just shown on the screen saying that it was resetting itself, as per instructions seems like that is performed one last time, and then it froze on that screen.

After 15-20 minutes I just turned it off and then turned back it on, but now it never finishes to boot up, it always stop in the “S90XS” screen. I’ve tried too many times, some times it gets to that screen, some times it just gets to the first screen where it shows the “YAMAHA” logo.

I’ve tried to re-attempt to update the firmware, however, that might not work as the firmware on the USB is the same on the S90XS, anyways, it just gets stuck in “Searching for firmware updater” but it never finishes. I’ve tried the firmware update sequence without the USB and it fails saying “USB memory not found” and then and then asks to press the “INC” button to re-attempt, so, I plug the USB drives but same, it just gets stuck in “Searching for firmware updater”.

I’ve looked around the internet for the Service Manual in order to “attempt” to boot it in Test Mode, but no luck, thus, now I’m wondering if the OS got corrupted or I need to under the hood, and try to measure voltages, signals, bad caps, ripple currents, etc?

If anyone have had a similar experience or mind to suggest what else I can attempt will be much appreciated.

Thank you!

P.D. As the images are not showing up on the “Preview” I"m adding the URLs just in case. Again, thanks!

  [ Ignore ]  

Posted on: October 21, 2021 @ 03:16 AM
Total Posts:  5
Joined  10-17-2021
status: Newcomer

Ok, after observing that the boot process some times it gets stuck early when the “Yamaha” logo shows up, some other times it gets to the “S90XS” screen, thus, following suit on what is discussed on this thread I proceeded to add some electrolytic caps in parallel next to the electrolytic caps at the output of the following ICs:

IC3021.25V DC-DC converter to power the CPU core
3.3V DC-DC converter that powers pretty much everything
2.6V regulator that powers the DDR_SDRAM
1.3V regulator that provides DDR_VTT

That last one, was a sort of “while there” and “just in case”. Then the very first thing I tried was booting into test mode while pressing and holding ”“ and the “[Stop]” button at the same time while powering up the S90XS and then releasing them when the S90XS logo shows up.

This time it boot up completely, prompted for the lower key and ran almost all the tests successfully. I skipped the pedals, audio and MIDI tests as I have completely disassembled the S90XS on my workbench.

Once I finished the tests, I realized that it was running fine with no freezing thus I proceeded with the last step on the test mode. Honestly, I prayed and then I ran the “Factory Reset”, when it finished successfully I did exit the test mode and the S90XS booted fine.

Next thing I did was to connect back the audio card and booted it up again, and so far everything is working fine. As the post mentioned above, I think I’ll try it out for a couple of days and if it stay stable, then I’ll proceed to order some replacement caps.

Hope the above info helps someone else in the future :)

  [ Ignore ]