mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Logic 9 and Motif XS lags while turning knobs"

     
Posted on: April 07, 2012 @ 09:36 AM
Vertical
Avatar
Total Posts:  209
Joined  12-12-2009
status: Enthusiast

Hello all
Had not been here for ages
I have an issue: When I play midi tracks in Logic 9 sequencer, they are assigned to Motif XS’s tracks in PATTERN mode. When I start turning any knob on motif’s panel, logic sequencer starts going down, tempo decreases. When I stop moving knob everything is going back to normal. If I start moving knob very fast left-right, tempo begin to decrease, and then a message appears on Motif screen “MIDI buffer full”.
What can I do in this case? Thanks

  [ Ignore ]  

Posted on: April 13, 2012 @ 08:59 AM
Bad_Mister
Avatar
Total Posts:  36620
Joined  07-30-2002
status: Moderator

Hello all
Had not been here for ages
I have an issue: When I play midi tracks in Logic 9 sequencer, they are assigned to Motif XS’s tracks in PATTERN mode. When I start turning any knob on motif’s panel, logic sequencer starts going down, tempo decreases. When I stop moving knob everything is going back to normal. If I start moving knob very fast left-right, tempo begin to decrease, and then a message appears on Motif screen “MIDI buffer full”.
What can I do in this case? Thanks

Welcome back. This sounds like a classic case of improper MIDI routing.

First: Make sure you are working with LOCAL CONTROL = OFF
If not, your knob and controller movements will travel directly to the tone engine and OUT via MIDI where your MIDI track dutifully echoes them back again to the tone engine. This “doubling” can be the cause of your sluggish response. Local Control should only be ON when working with an external recorder if:
1) you are recording Audio
2) you are recording Arpeggio data generated by the keyboard… And in this case you must ensure the MIDI data “dead ends” at the MIDI track *Turn DAW echo OFF*

In all other situation, and particularly when recording MIDI events you want to work with LOCAL CONTROL = OFF. Press [UTILITY] > Press [F5] > Press [SF2] MIDI > set Local Control off. This allows the currently selected MIDI track to determine which device is supposed to sound. (The trick is it should sound only once).
Or use the appropriate Quick [SEQ SETUP] for the task you are doing.

Next: verify your routing and read your DAW’s documentation on setting up MIDI tracks.

You should also learn to listen for and to recognize MIDI doubling of signal. It has a distinct sound that should alert you to such routing problem, you should not have to wait for sluggishness to recognize this issue. Crash cymbals sound swishy even wishy-washy when you are getting this doubling.

It can lead to MIDI buffer full and worst case it can crash your computer. Let us know

  [ Ignore ]  

Posted on: April 13, 2012 @ 12:32 PM
motif8mine
Avatar
Total Posts:  1743
Joined  10-22-2004
status: Guru

One other thing to check, (if you are connected via usb of mLAN, you don’t say) is the status of the remote port. If tempo is being affected and you are not in remote mode on the XS, I would also check to make sure that the Mackie Control is set to port #2.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ Recording sequencer-to-sequencer in Logic 8
Next Topic:

    Logic with Motif XF and FW16E ››