mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Midi notes out of SYNC when recording motif xs6 into Logic 8"

     
Posted on: February 11, 2010 @ 10:12 AM
axxe
Total Posts:  71
Joined  03-20-2009
status: Experienced

When i record midi into logic( external instrument track, sequencing in logic ), I quantize the notes and can clearly see that the notes line perfectly up on each beat.. However, they still sound off. Like midi latency..It does not matter whether I am in voice, song or pattern mode on the motif. I use the usb connection as midi and if i use the song/pattern mode on, i have my motif set to recording on computer..

I would appreciate any help…

Thanks

  [ Ignore ]  

Posted on: February 11, 2010 @ 12:10 PM
motif8mine
Avatar
Total Posts:  1743
Joined  10-22-2004
status: Guru

Ok, without getting into merits of hard quantizing, there’s really not enough information here…

Are attempting to sync the XS with Logic? If so, the Quick Setup Function should be set to Quick Setup>[F3]>#2 (Recording Internal Sequencer to Computer) instead of #3 (Recordng to Computer)

  [ Ignore ]  

Posted on: February 11, 2010 @ 02:58 PM
axxe
Total Posts:  71
Joined  03-20-2009
status: Experienced

No, Im recording everything straight into Logic: I dont touch the xs`sequencer..

  [ Ignore ]  

Posted on: February 11, 2010 @ 06:33 PM
motif8mine
Avatar
Total Posts:  1743
Joined  10-22-2004
status: Guru

What makes you think that it’s MIDI latency then? I’ve been recording MIDI for 15 plus years and have never experienced any MIDI Latency…

I have no clue as to why things would sound off other than the fact that everything is quantized on the beat, which is not musical. No musician is capable of playing exactly on every beat let alone 10% to 15% of the beats.

The only thing I can suggest is to isolate the parts with say- the drums and, either shift the notes forward or back until the track sounds correct…

  [ Ignore ]  

Posted on: February 11, 2010 @ 07:04 PM
motif8mine
Avatar
Total Posts:  1743
Joined  10-22-2004
status: Guru

I will clarify one thing: typically audio latency is a much more common occurrence. And, that is cured by increasing the setting of Logic’s buffer.

  [ Ignore ]  

Posted on: February 24, 2010 @ 02:14 AM
motif8mine
Avatar
Total Posts:  1743
Joined  10-22-2004
status: Guru

I just remembered something that may help you out… A while ago, we had the following discussion:

motif8mine - 27 March 2009 04:53 PM
axxe - 27 March 2009 04:10 PM

All i did was check the sysex box below and the xxx´s are gone. Now i have solved that problem.

Axxe, congratulations…
I’m glad that you found a work around and I really mean that but, at this point, that’s all it is is a work around. This is not to discourage you. A work around is a great thing.

I did note the sysex messages in your event editor. That’s what reminded me of the problem I had with the initial Yamaha USB/MIDI Driver. I don’t believe it was Intel Mac compliant. And perhaps, if it’s not your driver, we were looking at the wrong thing and somehow you’ve turned on a setting within the XS to transmit the sysex.

Below I have a pic of the same setting in my copy of Logic. Note: it’s unchecked. So, the messages are coming from somewhere (the XS via setting or the driver forwarding messages it should not) and you’ve successfully filtered them out (sorry, i didn’t think of that). At some point down the line, after the frustration of this past week is gone, you may want to look into why it’s being transmitted…

Anyway, sorry I couldn’t have been of more help…

I never explained why you wouldn’t want to use that workaround.

motif8mine - 24 February 2010 01:40 AM

One note: there is a workaround. There is also a very good reason why you would not want to use it. The workaround is to turn on, a sysex filter within Logic. By doing this, Settings> MIDI> Input Filter and check System Exclusive.

Why wouldn’t you want to do this? Because there is a limit to how many MIDI messages can be received on any sequencer at one time. And, the presence of these sysex messages are still being received and can ‘choke’ the MIDI Bus, throwing off the accuracy of note timing and playback… And, these sysex messages are not just being transmitted when you are recording, they are always present.

Therefore, the best solution is to find the source of the sysex messages and turn it off or eliminate it at the source as it will eliminate any future problems you may incur…

If you uncheck that System Message filter and sysex reappear in your MIDI regions, that may be the cause of the timing issues you are experiencing… One chief culprit is the Control Surface Ports within Logic being set to the wrong XS port…

  [ Ignore ]  


 
     


Previous Topic:

‹‹ motif xs6 in Logic 9
Next Topic:

    Work Flow ››