mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "MOXF8 not recognizing Sys Ex Mode Change"

     
Posted on: September 22, 2022 @ 09:24 AM
cassdad
Total Posts:  63
Joined  04-30-2009
status: Experienced

I have searched for and read numerous posts from 5pinDIN and Bad Mister on the subject of sending to my MOXF8 a MIDI System Exclusive message to change the MODE.  (I have songs on an iPad Pro, using “forScore”, and want to send the Mode and the Program Change each time I call up a new song in “forScore”.)

When I am in a “Mode” (e.g. Voice or Performance), my MOXF8 correctly responds to the Program Change MIDI messages for that Mode.  But if I’m in a Mode, and send the Sys Ex code to change the Mode, my MOXF8 is not responding to the Sys Ex Mode Change.  (e.g. If I am in Voice Mode, and pull up a song that sends Sys Ex Mode Change to “Performance”, my MOXF8 does not respond to the Mode Change.  If I manually place my MOXF8 into “Performance” mode, then it WILL respond to the Program Change for that mode.)

From reading your numerous subject posts, and reading the Data Format manual, my best guess is that the correct Hex Code to send via MIDI to change the MOXF8 Mode to “Performance” is:

F0 43 1n 7F 1C 00 0A 00 01 0m F7 [where n = Device number zero or one, and m = 1 for Performance Mode].

Any ideas on why my MOXF8 is not responding to the Mode Change Sys Ex hex code?  I’m at my wits end trying changes to all the MOXF8 MIDI and USB settings I can find, all to no avail.  Any thoughts on what the settings should be, or what I should look for?

Any help would be most appreciated.

  [ Ignore ]  

Posted on: September 22, 2022 @ 11:59 AM
lastmonk
Avatar
Total Posts:  339
Joined  12-17-2013
status: Enthusiast
cassdad - 22 September 2022 09:24 AM

I have searched for and read numerous posts from 5pinDIN and Bad Mister on the subject of sending to my MOXF8 a MIDI System Exclusive message to change the MODE.  (I have songs on an iPad Pro, using “forScore”, and want to send the Mode and the Program Change each time I call up a new song in “forScore”.)

When I am in a “Mode” (e.g. Voice or Performance), my MOXF8 correctly responds to the Program Change MIDI messages for that Mode.  But if I’m in a Mode, and send the Sys Ex code to change the Mode, my MOXF8 is not responding to the Sys Ex Mode Change.  (e.g. If I am in Voice Mode, and pull up a song that sends Sys Ex Mode Change to “Performance”, my MOXF8 does not respond to the Mode Change.  If I manually place my MOXF8 into “Performance” mode, then it WILL respond to the Program Change for that mode.)

From reading your numerous subject posts, and reading the Data Format manual, my best guess is that the correct Hex Code to send via MIDI to change the MOXF8 Mode to “Performance” is:

F0 43 1n 7F 1C 00 0A 00 01 0m F7 [where n = Device number zero or one, and m = 1 for Performance Mode].

Any ideas on why my MOXF8 is not responding to the Mode Change Sys Ex hex code?  I’m at my wits end trying changes to all the MOXF8 MIDI and USB settings I can find, all to no avail.  Any thoughts on what the settings should be, or what I should look for?

Any help would be most appreciated.

If I understand you correctly, you’re trying to change MoxF Modes from ForScore using Sys Ex messages that you are sending from For Score to MoxF

Just as a matter of troubleshooting make sure that ForScore is actually sending the complete sys ex message to the MoxF in the first place.

Have you tried setting up master mode so that it contains
all your performance or voice mode changes.  And then while the MoxF is in Master Mode send the Sys Ex message from For Score to select the appropriate master mode change.

I don’t have an Ipad that I can use to test this at the moment.  But whenever I communicate with my Mox or Motif from an external midi source I’m in either, Song Mode, Pattern Mode, or Master Mode.

Communicating with the MOXF while its in Voice or Performance Mode from an external midi device can be a little tricky.

Are you sending the Sysex message from For Score using a custom button in For Score?  If so make sure the custom button is really doing what you think its doing.

My reflex is telling me its easier to try to manipulate your MoxF while its in, Master Mode, Song Mode, or Pattern Mode.  Because Master Mode allows you to store Voices, Performances, Songs, and Patterns, that’s probably your best bet.  But sense I don’t have an Ipad and For Score available at the moment I can’t test that theory.

Also, you might be able to accomplish your goal indirectly by sending the message from For Score to some intermediate Ipad app e.g Notion, Cubasis, Dorico and then have that app communicate with MoxF. 

For instance, if you are trying to get the MoxF to automatically switch orchestration every time you change a song, or a section in For Score you could have For Score launch some other midi app on your Ipad for example Notion and then have Notion send the Midi to load a mixvoice in song mode that has the orchestration you want to play.  Or start the sequencer in song mode if you want For Score to actually trigger a sequence.

  [ Ignore ]  

Posted on: September 22, 2022 @ 03:27 PM
cassdad
Total Posts:  63
Joined  04-30-2009
status: Experienced

Thank you, last monk.  I will use Master Mode (as previously also suggested by Bad Mister) as a last resort.  However, all the documentation says the Sys Ex code I’m using should work....  but I don’t know of anyone who has actually done it, so have no evidence that it really does work as advertised.  Also, as best I can tell, it is actually sending the code, as it works flawlessly for Program Changes in the same app / window.

Still holding out hope that I simply may have some setting incorrectly set in the MOXF8, or the Sys Ex code I’m sending is incorrect.

  [ Ignore ]  

Posted on: September 23, 2022 @ 01:16 AM
piano-player
Total Posts:  49
Joined  02-21-2012
status: Regular

Hi, try this, I’m sending this from ForScore on iPad to my Moxf6 to go to Performance mode and it works for me:
F0 43 10 7F 1C 00 0A 00 01 01 F7

Kind regards from Sweden

  [ Ignore ]  

Posted on: September 24, 2022 @ 09:06 PM
cassdad
Total Posts:  63
Joined  04-30-2009
status: Experienced

Thank you, piano-player.... at least this confirms I’m not crazy.  That is EXACTLY the hex code I am transmitting from forScore.  However, it seems my MOXF8 is not recognizing it (or not responding to it).

Can you please advise what version of forScore you are using?  it used to work for me, but I think it recently updated, and may not be working in my current forScore version = 13.1.3 Is that the forScore version you are using?

On my MOXF8, I am using firmware version V1.12.0 Is that the MOXF version you are using?

I sincerely appreciate your help!

Best regards.

  [ Ignore ]  

Posted on: September 26, 2022 @ 12:14 AM
piano-player
Total Posts:  49
Joined  02-21-2012
status: Regular

Hi Cassdad, I’m quite busy this week, might take me a few days before I’ve checked the versions and can get back to you.

However I’m quite certain that I don’t have the latest version of ForScore and if I rembember correctly I have got the latest version of firmware for my MOXF6.

Does you MOXF receive other messages from FS?
I had trouble a couple of days ago at a gig, the MOXF didn’t receive any messages at all from FS.  I’m guessing my cheap USB-C hub has broken down.
Gonna try with an apple hub and see if I can get it to work again!

Kind regards from Sweden

  [ Ignore ]  

Posted on: September 26, 2022 @ 09:41 AM
cassdad
Total Posts:  63
Joined  04-30-2009
status: Experienced

Piano-player:  Yes, FS sends and my MOXF8 receives and responds to program change messages correctly.  I’ve also tried a different USB hub, no change.  A while ago, all was working correctly (PC changes and Sys Ex messages).  But I think recently forScore “updated” with 2 new updates, and now Sys Ex seems to not be working.  I don’t know how to roll back the FS version, so can’t verify.  I’ve tried contacting forScore, with no response.  I would love to know which version of FS you are successfully using.  Regards and thanks.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ MOXF store on USB stick