mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Sending SysEx From KB Controller to MOXF via USB"

     
Posted on: July 10, 2021 @ 02:37 PM
MarkJohnson
Total Posts:  68
Joined  09-03-2013
status: Experienced

I have a controller keyboard that sends SysEx commands from 8 sliders to change the volume of each of the 8 elements in a MOXF voice.  This works great when I have the controller connected to the MOXF via direct MIDI; however, when I change the MIDI In/Out parameter (UTILITY > F6) from MIDI to USB using Cubase, Note On/Off and sustain commands will control the MOXF, but SysEx commands don’t seem to be getting through.  In the Inspector of the MIDI track in Cubase, I’ve set the Input to Port 3 (my controller) and the output to Port 1. 

Why isn’t the SysEx getting through from the controller to the MOXF in this configuration.

  [ Ignore ]  

Posted on: July 10, 2021 @ 04:21 PM
5pinDIN
Avatar
Total Posts:  11891
Joined  09-16-2010
status: Legend

I don’t use Cubase, but I suspect that your installation of it is configured to filter out SysEx messages. There are probably MIDI Filter preference settings. Make sure that SysEx Thru isn’t being filtered. It’s often done by default because excessive SysEx data can slow/clog MIDI, so it’s best blocked when not needed.

  [ Ignore ]  

Posted on: July 11, 2021 @ 04:57 AM
MarkJohnson
Total Posts:  68
Joined  09-03-2013
status: Experienced

You nailed it!  I completely forgot about the filter settings in Preferences > MIDI > MIDI-Filter and I had SysEx being filtered out.

Thanks!

Image Attachments
Screen Shot 2021-07-11 at 8.53.51 AM.png
  [ Ignore ]  

Posted on: July 11, 2021 @ 10:45 AM
5pinDIN
Avatar
Total Posts:  11891
Joined  09-16-2010
status: Legend
MarkJohnson - 11 July 2021 04:57 AM

You nailed it!  I completely forgot about the filter settings in Preferences > MIDI > MIDI-Filter and I had SysEx being filtered out.

Thanks!

You’re welcome - I’m glad that was the solution.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ How can I live-control the Pan of my parts?
Next Topic:

    Using P 125 with MOXf6 ››