mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Turning OFF Arp Button as power-on DEFAULT"

     
Posted on: June 10, 2020 @ 11:58 AM
Pianofitz
Total Posts:  3
Joined  06-10-2020
status: Newcomer

I have a MoxF8. By default, when powered on, I want it set to Full Grand Piano. PERIOD.

Previously, I have had the Power On Mode set to be PRE1 in order to accomplish this, and this has worked fine.

Suddenly, today, whenever I power on, the unit still comes on in Voice mode, set to Grand Piano, as always, but—THE ARPEGGIATOR IS TURNED ON.

What I would prefer is: Turn on power—unit comes on, set to Grand Piano, ARPEGGIATOR BUTTON IS OFF.

I have tried saving the voice to USR1—with the arp button off—and setting the power on mode to USR1. Comes up with the right voice… and turns on the arpeggiator.  No.  Wrong.  Thanks anyway.

I have tried UTILITY - JOB - FactorySet.  Unit then powered up in Performance mode with MOX Flash, as it did when new out of the box.  Set it to power up to PRE1 instead.  Unit then comes up as Full Grand Piano.  WITH THE DAMN ARPEGGIATOR TURNED ON.

I have also tried setting the TYPE of the particular arpeggiation that it keeps defaulting to (ARP4) to Type: OFF.  Then, sure enough, that arp comes up selected by default.  Great.  Except that with Arp Type = OFF, and the Arp button lit, I then get NO SOUND AT ALL, which is not much of an improvement.  (Turn Arp button off, all is good again.)

==

TL;DR I just want the MoxF8 to NOT turn on the Arp button when first powered on.

(Creating an arp mode wherein the piano PLAYS, but normal/non-arpeggiated, would be an acceptable workaround.)

==

Thanks for any help you can provide. I am about ready to fetch a sledgehammer!

  [ Ignore ]  

Posted on: June 10, 2020 @ 12:37 PM
Pianofitz
Total Posts:  3
Joined  06-10-2020
status: Newcomer

Before posting the question, as you might be able to tell from the “things I have tried”, I spent several hours attempting to diagnose the problem.

Posting a forum question was my last resort, not my first. :)

I am still interested in how a default for the Arpeggiation button might be set, if you have any insights there.

However, I have since discovered the cause of the problem:

A day or two ago, I had been swapping some cables around, plugging and unplugging things, swapping some audio feeds, and… I accidentally plugged something random into Assignable Foot Switch.

==

Apparently, if you plug “something random” into Assignable Foot Switch, the MoxF thinks that the Arp light needs to come on.

==

Anyway, also, thanks everyone for making this valuable community resource what it is.

  [ Ignore ]  

Posted on: June 10, 2020 @ 02:24 PM
5pinDIN
Avatar
Total Posts:  11417
Joined  09-16-2010
status: Legend

As a side-note…
The Control Change number for the Assignable FS can be set via Utility mode. “Arp sw” (CC#96) will allow control of ARP on/off via the footswitch - a sustain footswitch connected to the assignable jack will alternately toggle ARP on/off as the footswitch is operated. See page 146 of the MOXF Reference Manual.

I have no idea if that in any way relates to your experience. I have a Motif XF, and even with the CC#96 setting it ignores the footswitch position until fully booted. What the MOXF does during boot-up could be different - I don’t have one to check.

  [ Ignore ]  

Posted on: June 10, 2020 @ 11:09 PM
Pianofitz
Total Posts:  3
Joined  06-10-2020
status: Newcomer

Yes, it was definitely Just After Boot. Logo displays, logo clears, up comes the name of the power-on voice, the usual lights light up, all set—then, a very slight pause and *BINK* the ARP light also comes on, just after everything else.

No doubt that half-second-just-after-boot timeframe is when the first polling of the foot switch jack occurs.

==

I have to say, upon encountering Weird Settings Behavior, my first instinct was definitely NOT Checking The Cables In The Back. Instead, I spent a long time Mashing The Buttons In The Front! :)

So: “ALSO, check the cables in the back!” is now definitely on my emergency checklist.

==

Thanks for the cordial reply!

  [ Ignore ]