mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Performance part volume control with local control off?"

     
Posted on: May 26, 2020 @ 02:45 AM
Kier
Total Posts:  4
Joined  06-17-2014
status: Newcomer

My apologies if this has been asked and answered before, but if it has I couldn’t find it so…

When I have my XF connected over USB to my Mac running Logic, I do the usual [Seq Setup > Quick > 3] routine in order to turn off local control, then I set up a track in Logic using the External Instrument plug-in etc. (see attached track setup.png)

But things fall apart somewhat when I use Performance mode. With local control turned off, whenever I use the first four Motif faders to control the volume of the four parts of the performance, I see the fader hook the volume indicator, but then within a second or so, the volume indicator returns to its original position and ignores the fader.

I looked to see if Motif XF Editor might have some control, but of course it only works in voice, pattern or song mode.

Am I missing something here in order to allow those faders to work as expected?

Thanks in advance for any pointers.

Image Attachments
track setup.png
  [ Ignore ]  

Posted on: May 26, 2020 @ 05:03 AM
5pinDIN
Avatar
Total Posts:  11379
Joined  09-16-2010
status: Legend

Turning off Local Control prevents messages generated by slide control operation from being effective. What you’re experiencing isn’t specific to Performance mode - you could see the same behavior in Voice mode, for example.

With Local Control “off”, for proper operation the slider messages should be looped back to the XF via the DAW. Your DAW is apparently set up to not do that. Since I don’t use Logic, I can’t be specific, but typically the problem is caused by MIDI echo being turned off or System Exclusive (SysEx) data being filtered.

  [ Ignore ]  

Posted on: May 27, 2020 @ 04:19 AM
Kier
Total Posts:  4
Joined  06-17-2014
status: Newcomer

May I ask what DAW you use @5pinDIN, and whether your faders operate as expected with local control (quick setup - 3) in place, as I’ve now tried Logic, Garageband and Live and none of them seem to allow the faders to operate, despite MIDI Thru / echo being enabled (as far as I can tell) and no SysEx filters being in place?

Thanks for your time.

  [ Ignore ]  

Posted on: May 27, 2020 @ 06:15 AM
5pinDIN
Avatar
Total Posts:  11379
Joined  09-16-2010
status: Legend
Kier - 27 May 2020 04:19 AM

May I ask what DAW you use @5pinDIN, and whether your faders operate as expected with local control (quick setup - 3) in place, as I’ve now tried Logic, Garageband and Live and none of them seem to allow the faders to operate, despite MIDI Thru / echo being enabled (as far as I can tell) and no SysEx filters being in place?

I do all recording on the XF itself, so no DAW.

However, I’ve verified that the problem you’ve described when Local Control is off is due to lack of the Control Slider data being returned to the XF. If I run MIDI-OX and prevent it from echoing or have it disable SysEx, the problem occurs. If I run the Yamaha XF Editor (standalone in my case), and don’t have the “Thru” function (at lower right corner) turned on, the problem exists. (Yes, I know the Editor doesn’t have a Performance mode, but Thru doesn’t care what mode the XF is in.)

Someplace in your setup the slider messages are being prevented from getting back to the XF.

For example, I found this for Logic Pro 8…
https://discussions.apple.com/thread/2327727
...in which the solution is given in the last post of the thread.

There are likely similar situations for other DAWs.

 

Kier -

Thanks for your time.

You’re welcome. I hope you find what’s stopping the slider messages.

  [ Ignore ]  

Posted on: May 27, 2020 @ 07:33 AM
Kier
Total Posts:  4
Joined  06-17-2014
status: Newcomer
5pinDIN - 27 May 2020 06:15 AM

If I run the Yamaha XF Editor (standalone in my case), and don’t have the “Thru” function (at lower right corner) turned on, the problem exists. (Yes, I know the Editor doesn’t have a Performance mode, but Thru doesn’t care what mode the XF is in.)

To be honest, the ins and outs of Logic’s MIDI handling is quite possibly beyond me, but your mention of the XF Editor has revealed a workaround of sorts - all I need to do is to keep the XF Editor running, with Thru enabled, and full control of all parameters is obtained with the Motif’s knobs and sliders etc., which is all I really need at this point.

5pinDIN - 27 May 2020 06:15 AM

I found this for Logic Pro 8…
https://discussions.apple.com/thread/2327727
...in which the solution is given in the last post of the thread.

For the sake of having something here to act as future reference for anyone else who comes up against this issue, I tracked down the setting mentioned in that discussions.apple.com thread, which is somewhat hidden in Logic Pro X - you have to enable [Preferences > Advanced Tools > Show Advanced Tools > MIDI] before the SysEx setting appears in [File > Project Settings > MIDI]. However, enabling this setting unfortunately made no difference to the operation of the knobs and sliders on my Motif, so I guess there’s something else at play.

Nonetheless, having the XF Editor open with Thru enabled solves my problem for the time being so I’m happy for now.

Thanks again, @5pinDIN.

  [ Ignore ]  

Posted on: May 27, 2020 @ 09:44 AM
5pinDIN
Avatar
Total Posts:  11379
Joined  09-16-2010
status: Legend
Kier - 27 May 2020 07:33 AM

[...]

Nonetheless, having the XF Editor open with Thru enabled solves my problem for the time being so I’m happy for now.

Thanks again, @5pinDIN.

I’m glad you found that approach does the trick.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ Midi Editor Question or Mystery (Pattern Mode)
Next Topic:

    library compability XF and MODX ››