mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "MIDI Port 3 Sysex"

   
Page 2 of 2
Posted on: July 12, 2018 @ 03:05 PM
5pinDIN
Avatar
Total Posts:  10121
Joined  09-16-2010
status: Legend
Davelet - 12 July 2018 01:05 PM

Hi

I’ve done a bit more digging. The files that are successfully output via PORT3 on the MOXF start with:

F0 43 00 7F

Other Yamaha files that are not successfully output on PORT3 are, for example, DX7 files starting with:

F0 43 00 09

and FS1R files starting with:

F0 43 00 5E

So it’s not only filtering non-Yamaha messages, it’s filtering non-MOXF messages it seems. [...]

The Model/Product ID for the MOXF is the fourth and fifth bytes, which would be “7F 1C”.

I can appreciate your wanting to take a break from all this. You might find this thread “interesting”:
http://www.motifator.com/index.php/forum/viewthread/459808/

There’s a MIDI Filter setting for “Exclusive” in the MOXF, but it should only affect messages embedded in sequences. See page 144 of the MOXF Reference Manual.

There was a “fix” that was done starting with the MOXF OS version 1.10 :
- Solved a problem that SysEX messages which were received over a port other than Port 1 were recorded to a Song.
I wonder if that “fix” might have “broken” something else.

  [ Ignore ]  

Posted on: July 12, 2018 @ 03:30 PM
wonderer
Avatar
Total Posts:  29
Joined  10-11-2017
status: Regular

Some more info for whenever your break is over ;-)

I noticed some strange behavior in my MoXF with OS V1.03 that might be of interest.

The sysex dumps that come from the Motif XF via MIDI connected to the MoXF take over 3 times longer to arrive then via Motif XF USB. Note: The Motif XF is already 1.5 times faster via USB then the MoXF via USB.
Because of this delay, it seems the sysex’s aren’t directly put through to port 3, but are being processed in the MoXF before being send to port 3.

When I send sysex’s to port 1, 2, 3, 4, the MoXF accepts them and responds to them. So even the MIDI thru can be used to control my MoXF. The only port that it doesn’t accept messages from is port 5.
This might cause a problem that Yamaha has addressed and “fixed” in OS V1.10. “Solved a problem that sysex messages which were received over a port other than Port 1 were recorded to a Song.”
It might be that the “fix” has caused this “MIDI thru problem” if they “fixed” it after filtering for MoXF/Motif XF messages (For both they start with “F0 43 00 7F").

If so. that would mean that both OS V1.10 and OS V1.12 should have this problem and only OS V1.03 doesn’t.

  [ Ignore ]  

Posted on: July 12, 2018 @ 05:29 PM
5pinDIN
Avatar
Total Posts:  10121
Joined  09-16-2010
status: Legend
wonderer - 12 July 2018 03:30 PM

[...]"Solved a problem that sysex messages which were received over a port other than Port 1 were recorded to a Song.”
It might be that the “fix” has caused this “MIDI thru problem” if they “fixed” it after filtering for MoXF/Motif XF messages (For both they start with “F0 43 00 7F").

If so. that would mean that both OS V1.10 and OS V1.12 should have this problem and only OS V1.03 doesn’t.

Yes, I mentioned this possibility in my previous post.

I encourage Davelet to contact Yamaha Support and make them aware of his findings. Since the MOXF is still in production, Yamaha should investigate, and if the problem is verified it should be fixed in an OS update.

  [ Ignore ]  

Posted on: July 13, 2018 @ 01:20 PM
wonderer
Avatar
Total Posts:  29
Joined  10-11-2017
status: Regular
5pinDIN - 12 July 2018 05:29 PM


Yes, I mentioned this possibility in my previous post.

I only saw your message right after I sent mine, otherwise I would have changed it a bit.

I encourage Davelet to contact Yamaha Support and make them aware of his findings. Since the MOXF is still in production, Yamaha should investigate, and if the problem is verified it should be fixed in an OS update.

I agree, that’s the best way to go.
As for me, I’m glad I never updated my MoXF, and I most likely never will, unless there’s a way to downgrade it again.

  [ Ignore ]  

Posted on: July 13, 2018 @ 01:46 PM
Davelet
Total Posts:  40
Joined  07-27-2017
status: Regular

Hi Guys

I’ve had a lovely evening making music and not battling with MOXF sysex and feel refreshed.

When I have got my patience back with it, I’ll look at the MIDI filter thing in the song/pattern utility mode and see if changing that changes anything. If not I’ll contact Yamaha support in due course. I’ll let you know either way.

The thread you sent over 5pinDIN was interesting - interesting that someone was having and identical problem but with the Tyros 3 keyboard.

David.

  [ Ignore ]  


Page 2 of 2