mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Key-on audio in Song mode"

     
Posted on: February 10, 2018 @ 08:06 PM
cal900
Total Posts:  23
Joined  08-12-2013
status: Regular

Greetings fellow Motifians.  I have a curious event happening with three tracks in song mode that have had audio .wav’s successfully associated (stored on my FL1) on tracks 9 thru 11 with their key-on and -off events since almost a year ago.  To my surprise, the key-on and -off notes are suddenly playing the voice assigned to track one with no known reason on my part.

I tried to figure this out for hours with no guess as to what it’s doing.  I reloaded the song from a “song all-file” backup which, after a few successful plays, it corrupted again.

Any guesses from anyone will be gratefully welcomed…

  [ Ignore ]  

Posted on: February 12, 2018 @ 04:20 AM
5pinDIN
Avatar
Total Posts:  10479
Joined  09-16-2010
status: Legend

There are a few ways that the Voice being used to play a Part can be changed, but none that I know of are spontaneous. Since some unusual problems have occurred with older OS versions, the first thing I’d check is that the most recent OS version is installed in your XF…
Press [UTILITY] to enter the Utility mode.
Press [UTILITY], [ ^ ](Cursor Up) and [F1] buttons simultaneously.
Read the firmware version, ignoring the second decimal point and anything after it. Version 1.50 is the most recent. If yours isn’t that, I suggest updating it and then see if the problem is resolved.

Otherwise, at a time when the Song isn’t playing correctly…
1) Select a different Song
2) Reselect the Song with the problem, but don’t play it
3) From the Song Play screen, make note of the names of the Voices displayed for tracks 1 and 9~11. Are the names for 9~11 the same as for track 1? If yes, stop and let us know. If not, continue with #4…
4) Play the Song
5) Do the Voice names for tracks 9~11 change? If so, make note and let us know.

  [ Ignore ]  

Posted on: February 12, 2018 @ 05:51 PM
cal900
Total Posts:  23
Joined  08-12-2013
status: Regular

Thank you so much for the reply 5pinDIN!  In processing your steps, I managed to find what the problem was.  Track 9-11 voices never changed, but I found out track one changed on every song (20 songs), taking the voice from track 8, and it’s midi channel!  I found it was a quirky YSFW driver corruption, as I had the XF on Quick Setup 3 into my computer.  I neglected to add that fact not knowing it had anything to do with this condition.  I’ve never seen this for the four years I had this XF.  I guess the value for the reader may be that if anyone sees this happen to them, a computer and keyboard restart may answer the problem (as it does for almost all problems).  You think I would have done that?  Noooo.  Nevertheless, I’m up and running.

Once I saw the steps in your reply I saw where you were going with this.  This is great troubleshooting.  I so appreciate all the difficult conditions in which you help users, and the incalculable amount of time you put in to reply to these troubles.  The biggest thanks to you!

  [ Ignore ]  

Posted on: February 13, 2018 @ 05:26 AM
5pinDIN
Avatar
Total Posts:  10479
Joined  09-16-2010
status: Legend

You’re welcome. I’m glad that you were able to resolve the problem.

  [ Ignore ]