mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Mode Change SysEx Command Works with MIDI I/O but not via USB"

     
Posted on: June 09, 2016 @ 06:53 AM
tonygardner
Total Posts:  26
Joined  08-14-2015
status: Regular

Hey Guys.
I ran into a strange problem where I can send a Mode Change to my XS Rack so it changes from Voice to Multi mode using the following command:
F0 43 10 7F 03 0A 00 01 05 F7

I am also sending MSB/LSB 063/068/nnn a second later, and that makes the program change with no problem.

This ONLY works if I go to Utility, set the MIDI Mode to MIDI, and use a 5-pin DIN from my controller to the MIDI IN port on the XS Rack.

Once I set the MIDI Mode to USB, the same command no longer works.
HOWEVER, the MSB/LSB 063/068/nnn DOES work. It’s only the Mode Change that is being ignored by the XS Rack.

Here’s my configuration:
XS Rack with Firmware 1.0.4 (includes program change fix)
Laptop running Windows 10 with latest versions of Studio Manager, XS Editor, MIDI drivers, etc.
MOTU USB interface has 5-pin DIN with Port A IN receiving keyboard’s GM OUT on channel 1.
Griffin Studio Connect for iPad running Arlo Media’s Bandhelper app is sending SysEx commands via the OUT port.
Dual OUTs accomplished using Midi Solutions Merger.

My apologies, I’m sure this is very confusing. I’ll continue to try to clarify and answer any questions you might have.

Thanks!

  [ Ignore ]  

Posted on: June 09, 2016 @ 08:55 AM
meatballfulton
Avatar
Total Posts:  2969
Joined  01-25-2005
status: Guru
tonygardner - 09 June 2016 06:53 AM

Once I set the MIDI Mode to USB, the same command no longer works.

How are you sending the sysex? You mentioned connecting your controller via MIDI cables. Obviously you cannot connect a controller directly to the XS via USB, you need a computer in between. Check all possible MIDI filters in the path to make sure sysex is not being disabled.

  [ Ignore ]  

Posted on: June 09, 2016 @ 01:29 PM
tonygardner
Total Posts:  26
Joined  08-14-2015
status: Regular

I do believe I’ve contradicted myself! Let me try again…

There is no MIDI controller in the current configuration. I’m using my old Alesis QS8.2 so I can have a keyboard until I get things sorted out.

The SysEx messages are only being sent from the BandHelper app. I don’t know how to do it any other way. Suggestions for alternatives for testing purposes would be appreciated.

The Midi Solutions Merger doesn’t filter messages. They have other models which do, but not this one.

The MOTU Fastlane might be the culprit, but it’s the only way I can think of to get my QS8.2 talking to the laptop so note changes get sent to the XS Rack. I would very much appreciate any suggestions for a cleaner way to get this rig cleaned up. Of course, I will also follow up with MOTU to see if they have any ideas, but the driver was downloaded two days ago.

There’s a USB cable going from the laptop to the XS Rack. That could be bad, so I’ll certainly try swapping it out.

There’s another USB cable going from the laptop to the MOTU. Again, possibly bad and will swap that out too.

As always, you’re helpfulness is greatly appreciated!

  [ Ignore ]  

Posted on: June 10, 2016 @ 03:55 AM
meatballfulton
Avatar
Total Posts:  2969
Joined  01-25-2005
status: Guru

If other MIDI is getting across the USB cables, then the cables are fine.

You wrote you can get it to work using MIDI cables, so I assume you are doing this:

BandHelper -> USB cable -> MOTU USB -> MOTU MIDI out -> MIDI cable ->XS MIDI IN

Is this correct? This works properly?

Where is the merger being connected?

  [ Ignore ]  

Posted on: June 10, 2016 @ 05:58 AM
tonygardner
Total Posts:  26
Joined  08-14-2015
status: Regular

The configuration I use to get the SysEx working is this:
[Utility] [MIDI] = MIDI
BandHelper -> iPad -> StudioConnect -> MIDI Out -> XS Rack MIDI In

The configuration that doesn’t support SysEx is this:
[Utility] [MIDI] = USB
BandHelper -> iPad -> StudioConnect -> MIDI Out -> MOTU Fastlane Port A In -> USB cable to Laptop -> Windows MIDI Drivers (MOTU and Yamaha] -> USB cable -> XS Rack USB In

Last night I did take some time to browse through the MOTU support site. That’s why there’s no more Midi Solutions Merger in the mix (I now use Port B to connect the QS8.2 to the configuration. It didn’t solve the problem, but it’s one less box to hook up.

Cheers,
Tony G.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ The Motif-Rack XS quit recognizing.
Next Topic:

    Mapping voicechange on midiboard ››