mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "moX6 USB Problem"

     
Posted on: May 29, 2015 @ 07:20 PM
keyboard55
Total Posts:  2
Joined  03-12-2013
status: Newcomer

i have been using John Melas’ Total Librarian (and others) with my moX6 and moXf8 for a few months.  Both had been working fine until recently.

Now, I cannot get the Total Librarian to connect to the moX6.  The moXf8 version works fine.  I have checked all settings, tried multiple cables, and use the latest software and drivers on my MacBook.

Questions:

1) Anyone else have this problem and/or a solution?

2) Is there any way to diagnose the moX6 USB port?

3) Other thoughts?

thanks in advance to all helpers

  [ Ignore ]  

Posted on: May 29, 2015 @ 07:57 PM
cmayhle
Total Posts:  3058
Joined  10-05-2011
status: Guru

I can’t give you any direct assistance with your issue, but I can provide a very helpful suggestion (if I may say so myself!):

Contact John Melas at directly.  He is not only very responsive and helpful, he may be the best source of assistance for this...there may be a known issue.  Plus, he’s a really nice guy.

  [ Ignore ]  

Posted on: May 30, 2015 @ 02:39 PM
my03
Avatar
Total Posts:  38
Joined  12-01-2014
status: Regular
keyboard55 - 29 May 2015 07:20 PM

1) Anyone else have this problem and/or a solution?

Have i ever. It drove me nuts. I can’t say for sure that you have the same issue as i had but let me ask you this:

Have you exhanged your usb-devices on your computer much and/or do you have heaps of usb connected synts and midi-interfaces?

Apparently, there is a limitation in windows (7 in my case but it has been there since xp afaik) where only 10 devices are visible to programs). If you for example remove a usb-connection from your computer and plug it in again in the port next to its original location, you will now notice that windows reserves “two” slots for this device: on “real” and one “ghosted” (shown in paler gray color). Remember that you have that limit......

solution that worked for me:

Create a new textfile on your desktop, name it “runme.bat” and include the following inside:

set devmgr_show_nonpresent_devices=1
start Devmgmt.msc

and save it. Run it (it will show the device manager) and select “view->hidden devices”. Look for any duplicates and if you find any, remove the lighter ones (the “ghosts").

When all this is done, restart the Melas tools again :)

  [ Ignore ]  

Posted on: May 30, 2015 @ 04:55 PM
keyboard55
Total Posts:  2
Joined  03-12-2013
status: Newcomer

Sincere thanks for the input trying to assist.

I emailed John Melas, and his response back was to verify MIDI via USB, which is set up properly.

Running Mac OS X, not Windows. I am certain the settings on the moX6 are correct, but don’t have a way to diagnose the USB port. Not using any DAW software.

Seems there should be something from Yamaha to diagnose the USB port..

New wrinkle: with both keyboards connected at the same time via usb cables, the MOX librarian is ¬≥seeing¬≤ the moXf8, but NOT the moX6. The other editors have the same behavior.  Would it make sense to try to re-install the moX package?  (I emailed this last bit to John Melas).

  [ Ignore ]  


 
     


Previous Topic:

‹‹ Sound Effects
Next Topic:

    FC3A Pedal vs FC3 ››