mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


Old Motifator threads are available in the Archive.

Viewing topic "DI box doesn’t remove hissing on my MOX8"

Posted on: January 07, 2015 @ 02:47 AM
Total Posts:  4
Joined  01-02-2015
status: Newcomer

I have a mox8 attached to a Behringer Passive DI box, connected to a single EV ELX112P. Not only is the sound quality complete garbage out of this supposedly “good” speaker, there is a very VERY loud hiss, even at low gains.

I thought a DI box would solve the hiss problem, but it didn’t do ANYTHING.

I don’t understand what the problem is. I have an amazing keyboard, a highly regarded stage monitor, and a decent DI box and yet the sound quality and hissing is complete crap.

Someone please tell me what I’m doing wrong. I don’t understand how all this expensive equipment I spent thousands of dollars on can sound worse and create worse ground loop than my $50 12 year old Yamaha. (And yes, I have messed with the FEG, AEG, and EQ levels on the keyboard and the speaker).


  [ Ignore ]  

Posted on: January 07, 2015 @ 05:36 AM
Total Posts:  293
Joined  08-02-2014
status: Enthusiast

Hi there

Do you have it connected to a PC with a USB cable?
Cutting the shield and black ground in that has solved the issue for myself and others if so.

  [ Ignore ]  

Posted on: January 07, 2015 @ 08:02 AM
Total Posts:  1092
Joined  10-02-2002
status: Administrator

It sounds like you’re using speaker cable instead of (shielded) instrument cable. Might I also ask why you are using the DI box? You can connect directly from the instrument outputs to the mixer on your EV.

Either way, check your cables!

  [ Ignore ]  

Posted on: January 07, 2015 @ 08:18 AM
Total Posts:  3017
Joined  01-25-2005
status: Guru

Is it hiss or hum? You mentioned a ground loop...that’s hum.

  [ Ignore ]  


Previous Topic:

‹‹ drum fills not on youtube
Next Topic:

    Why is there no battery version of mox or moxf? ››