mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Using FC2 as volume"

     
Posted on: October 30, 2013 @ 08:02 AM
MightyD
Total Posts:  8
Joined  12-13-2004
status: Newcomer

I’m trying to edit a string pad voice. I’ve got the FC2 set up as a volume pedal (source FC2, destination Volume, depth +63), and the voice volume (in voice common) set to 0. This sort of works; I can layer this in a performance with piano or rhodes and get a nice string pad backing controllable by volume pedal.

There’s a bug however and I’m wondering if it can be fixed.

What happens when I select the voice from “scratch” (e.g. go into voice mode, select any other voice, then reselect this voice) is that the volume is -not- at zero and I have to move the pedal to get it to zero. 

What I want is for the string pad’s volume to remain at 0 until the pedal “catches” at zero (just like sliders do). That way when I select the performance with the pad layer, it’s just the piano or rhodes until I bring in strings.

Is this possible, and if so...how? :)

Thanks in advance.

  [ Ignore ]  

Posted on: October 30, 2013 @ 09:26 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

I’m trying to edit a string pad voice. I’ve got the FC2 set up as a volume pedal (source FC2, destination Volume, depth +63), and the voice volume (in voice common) set to 0. This sort of works; I can layer this in a performance with piano or rhodes and get a nice string pad backing controllable by volume pedal.

You stop short of giving us the complete information to discover what you have done incorrectly. But we love a mystery… The SOURCE is FC2 but what control change number do you have it set to send? The default cc004 or did you change the number?

Also, just FYI, a DEPTH of +63 ensures that the pedal does not work for half of its travel. The linear positive Depth setting would be +32, not +63. At +63 no change in volume will occur for the first half of the travel of the pedal. Linear response would be approximately half the setting you have, +32, at this setting for each unit increase in movement of the control there is a increase in result.

We will assume your controller set is setup as follows:

(--------)
SOURCE = FC2(04)
DEST = volume
DEPTH = +32

And that you set the Voice’ main volume to 0. Since you don’t mention which S-series product you have we’ll forego the steps. This is a setup that would bias the volume of this Voice to the position of the pedal. Pedal at minimum = volume at minimum; Pedal at maximum = volume at maximum.

There is one bit of information that you need to factor in. In the MIDI spec Foot Controllers reset to maximum anytime a Program selection occurs… This is by a command called RESET ALL CONTROLLERS. This command is sent anytime a program is recalled.

There’s a bug however and I’m wondering if it can be fixed.[

there is no bug in the S-series as it concerns controllers. It’s how you are attempting to do this without knowing about the RESET ALL CONTROLLERs command, which is standard in MIDI.

What happens when I select the voice from “scratch” (e.g. go into voice mode, select any other voice, then reselect this voice) is that the volume is -not- at zero and I have to move the pedal to get it to zero.

It’s not a bug. How the Voice responds when you recall it is a matter how how you have your CONTROLLER RESET parameter set. According to what you say you have done, it is working exactly as it should.

If CONTROLLER RESET is set to RESET then all controllers return to the MIDI designated default value.
If CONTROLLER RESET is set to HOLD then as long as you are remain in the same mode the position of the controller will persist (remain) in the next program. So if the MW is left up, then the next Voice will inherit the last value of the MW, same for Foot Controllers, the position of the pedal is “live”.

File this bit of information away because it will be your preference as to how you want to accomplish your goal… Which is to have a Voice recalled in silence… Something the spec tries to prevent… But if you are clever you can do…

What I want is for the string pad’s volume to remain at 0 until the pedal “catches” at zero (just like sliders do). That way when I select the performance with the pad layer, it’s just the piano or rhodes until I bring in strings.

Well, there’s the trouble. What you setup is the opposite of what you want to do.

Here’s what you missed. It is a rule in MIDI (that 30 year old spec) that when a program is recalled controllers, unless told otherwise, will reset to certain settings.
Pitch Bend naturally returns to +0000; PB goes both above and below 0
MW returns to minimum (0); MW is always 0 through 127, minimum to maximum
Foot pedals, like the FC1/FC2, return to maximum, FC are always 0 through 127, minimum to maximum
Assign 1/2 return to +0, they go both above and below 0
Etc,

The spec makes it so that things default to the most “PLAYABLE”, never silence. Always: ready to play

If you would like a Voice to to start with silence, you correctly concluded you should set the main Voice volume to 0. But what you did not account for was the MIDI spec will automatically reset your FC to maximum… As soon as you call up the program.

Please realize, had you decided to bias the volume of the pad sound to the MW, your programming would have worked!!! Because when the RESET is sent, the MW goes to minimum, unlike the FOOT CONTROLLERS which default to maximum. See how that works?

YOUR OPTIONS for FC Pedals
You either have to set CONTROLLER RESET to HOLD and remember to move the pedal to HEEL DOWN position before playing… Not ideal, but this is an option

Or… You have to setup the Voice so that when the pedal is TOE DOWN or maximum (which you now know is the default) this equals 0 volume for that Voice.
You do this by setting the VOICE volume to a whatever playable value makes it sound as you like (not 0)
What you do is make the FC work in reverse, such that as you move it towards TOE DOWN you are actually fading it out. To bring it in you do the reverse you move your foot toward HEEL DOWN.

Here’s how:
Set the main VOICE Volume to its normal volume value
Set the Control Set as follows

(--------)
SOURCE = FC2(04)
DEST = volume
DEPTH = -32 (negative 32) this will reverse its affective direction.

Now when you use this pad sound in a Performance it will be recalled with volume of zero, to bring it in rock the pedal backwards.

It’s not a bug, its basic MIDI 102
:-)

Hope that helps.

  [ Ignore ]  

Posted on: October 30, 2013 @ 10:07 AM
MightyD
Total Posts:  8
Joined  12-13-2004
status: Newcomer
Bad_Mister - 30 October 2013 09:26 AM

You stop short of giving us the complete information to discover what you have done incorrectly. But we love a mystery… The SOURCE is FC2 but what control change number do you have it set to send? The default cc004 or did you change the number?

Heh. Ok we are referring to two different windows. I was referring to the control set assign when I specify control sets in a voice. You appear to be referring to the page in the utility section that says “controller”. I have this set to 4, which is the default (I did not really change it either).

Also, just FYI, a DEPTH of +63 ensures that the pedal does not work for half of its travel. The linear positive Depth setting would be +32, not +63. At +63 no change in volume will occur for the first half of the travel of the pedal. Linear response would be approximately half the setting you have, +32, at this setting for each unit increase in movement of the control there is a increase in result.

Who knew? :) Where, in reading through the documentation, is this mentioned? THANK you for clearing this up. I was wondering why I had to push the pedal so far forward. (N.B. when seated, it’s actually more comfortable to find the volume up there for my foot, so I might leave this set this way. Nevertheless thank you very much for clearing this up.)

Since you don’t mention which S-series product you have we’ll forego the steps.

I have an s90sx, recently upgraded from s90. :)

There is one bit of information that you need to factor in. In the MIDI spec Foot Controllers reset to maximum anytime a Program selection occurs… This is by a command called RESET ALL CONTROLLERS. This command is sent anytime a program is recalled.

...

How the Voice responds when you recall it is a matter how how you have your CONTROLLER RESET parameter set. According to what you say you have done, it is working exactly as it should.

If CONTROLLER RESET is set to RESET then all controllers return to the MIDI designated default value.
If CONTROLLER RESET is set to HOLD then as long as you are remain in the same mode the position of the controller will persist (remain) in the next program. So if the MW is left up, then the next Voice will inherit the last value of the MW, same for Foot Controllers, the position of the pedal is “live”.

Nice! Another missing piece of information. I thought the midi settings only applied to devices connected via midi and not internal control parameters.

If you would like a Voice to to start with silence, you correctly concluded you should set the main Voice volume to 0. But what you did not account for was the MIDI spec will automatically reset your FC to maximum… As soon as you call up the program.

Please realize, had you decided to bias the volume of the pad sound to the MW, your programming would have worked!!! Because when the RESET is sent, the MW goes to minimum, unlike the FOOT CONTROLLERS which default to maximum. See how that works?

YOUR OPTIONS for FC Pedals
You either have to set CONTROLLER RESET to HOLD and remember to move the pedal to HEEL DOWN position before playing… Not ideal, but this is an option

I do see how that works. This controller reset: hold is exactly the option I needed to set. I’m using your above method, and it *is* ideal...since once I bring the pedal down it *stays down* even if I change patches.

Thanks once again!

  [ Ignore ]