mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "MOTIF XF EDITOR ONLINE but no audio"

   
Page 1 of 2
Posted on: March 25, 2013 @ 03:08 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular

Have been struggling for a few days to get to grips with the FW16E + Cubase setup.

From my previous post I got it up and running importing a SONG but wanted to start new project from scratch to try and understand what I can do with the Motif XF + Cubase.

So have set a new project - added the Motif XF as the VSI Instrument - am ONLINE with the XF Editor.  The editor is receiving MIDI ok and records on a new MIDI track.  But no matter what I do I do not get any playback through the Motif XF.

When I play the Motif XF I see the keys being pressed so Cubase is receiving MIDI ok but noting goes back to the Motif XF.

I can’t see where I am going wrong.  In the device setup on MIDI OUT all is active but in the instructions these are not active.  Is the problem there?

Many thanks
Leslie

  [ Ignore ]  

Posted on: March 25, 2013 @ 04:24 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

So have set a new project - added the Motif XF as the VSI Instrument - am ONLINE with the XF Editor.  The editor is receiving MIDI ok and records on a new MIDI track.  But no matter what I do I do not get any playback through the Motif XF.

If the EDITOR is ONLINE that means you have MIDI routing that is fine. But no one has ever heard MIDI so it has nothing to do with hearing anything. So you need to troubleshoot your audio routing.

You have the Motif XF setup as a “VSI” (you mean VSTi). That is a place to start to check your audio routing.

MIDI data recorded to a MIDI track in Cubase is output to the “Motif XF VST MIDI IN” make sure that the MIDI track’s OUT is set to “Motif XF VST Midi In” - if not, set it so that it is.
The MIDI data on the Track is routed to the Motif XF VST editor which is ONLINE with the hardware - so it arrives in the hardware. Now you need to figure out where the audio that responds to this MIDI data is set to go…

Then on the Motif XF Editor click on FILE > VSTi SETUP

Here you can see where the audio goes that the Motif XF generates when it receives the MIDI data via the Motif XF VST.

The audio is considered RETURNING from the Motif XF and being routed somewhere.

This screen should tell you… let us know!

If you need more specific help… let us know what type of computer and version of Cubase you are running - the setup can be quite different depending on what you are doing/using.

  [ Ignore ]  

Posted on: March 25, 2013 @ 06:26 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Bad_Mister - 25 March 2013 04:24 AM


Then on the Motif XF Editor click on FILE > VSTi SETUP

Here you can see where the audio goes that the Motif XF generates when it receives the MIDI data via the Motif XF VST.

The audio is considered RETURNING from the Motif XF and being routed somewhere.

This screen should tell you… let us know!

Hi Bad_Mister many thanks for you assistance again.  So have checked the VSTi setup and all the audio ports are ‘not assigned’!  I don’t have the Motif XF in the drop down list and the Auto button is not available.

So something somewhere is not set-up correctly.

My setup:-

XF6 + FW16E
Mac Book Pro
Cubase AI5
XF Editor VST standalone version 1.6
XF Extension version 1.1.1

Many thanks
Leslie

  [ Ignore ]  

Posted on: March 25, 2013 @ 08:00 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

Please see the following setup Guide: A Getting Started Guide: Motif XF Editor VST

  [ Ignore ]  

Posted on: March 25, 2013 @ 08:49 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Bad_Mister - 25 March 2013 08:00 AM

Please see the following setup Guide: A Getting Started Guide: Motif XF Editor VST

Thanks but have been through this page a thousand times without success.

Have successfully played the Motif XF from the standalone Editor. So it must be something within Cubase?

Can record MIDI but not hear the resulting audio from the Motif when I try to play the MIDI track.  So I am missing something here. 

The only difference from your instructions is the Audio parts - mine does not say Motif XF 1 etc - mine says Yamaha FW 1.....etc.

The MIDI track linked is to the VST instrument - the in’s & out’s set to what exactly? - Motif XF Main or MIDI IN & OUT respectively - I have tried all combinations without success.

Coming to the end of day 3 and not a lot further....

Many thanks
Leslie

  [ Ignore ]  

Posted on: March 26, 2013 @ 03:59 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
abbaskunk - 25 March 2013 08:49 AM


The only difference from your instructions is the Audio parts - mine does not say Motif XF 1 etc - mine says Yamaha FW 1.....etc.

The MIDI track linked is to the VST instrument - the in’s & out’s set to what exactly? - Motif XF Main or MIDI IN & OUT respectively - I have tried all combinations without success.

Day 4.....

Well as if by magic am up and running recording a track and I am able to hear the result via the Motif XF.  Not worked out how to create track 2 yet…

Anyway went back to the imported song and set-up - all seems to be working!  Just when I thought I was heading in the right direction.  I tried an Export to Audio.  The resulting files were blank so Cubase is not receiving the Audio from the Motif XF.  All the Audio routings seem OK.

Any thoughts?  Many thanks
Leslie

  [ Ignore ]  

Posted on: March 26, 2013 @ 08:42 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

“Well as if by magic...” no, when you set it up right it works every single time. When it does not work there is always a reason. There is no magic in this, none.

When you seek to EXPORT > AUDIO MIXDOWN, you must meet the requirements of that operation. If the file comes out blank it is because you did not meet the requirements.

These include, setting the Left/Right markers, selecting the attributes in the dialog box, and most importantly recognizing that only audio tracks or virtual audio tracks can be mixed down.  MIDI tracks cannot be rendered via AUDIO MIXDOWN because MIDI makes no sound.

You can record MIDI TRACKS if they are routed to a synthesizer (XF) and that synthesizer is setup to RETURN audio to your DAW… via FW.

Have you fulfilled those requirements?
You need to know how you are routing the audio to return to the DAW.

  [ Ignore ]  

Posted on: March 26, 2013 @ 09:37 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Bad_Mister - 26 March 2013 08:42 AM

MIDI tracks cannot be rendered via AUDIO MIXDOWN because MIDI makes no sound.

Many thanks for you reply - that makes perfect sense.

You can record MIDI TRACKS if they are routed to a synthesizer (XF) and that synthesizer is setup to RETURN audio to your DAW… via FW.

This is where I am getting stuck.  As far as I can see all the FW channels are configured in the Motif XF Editor.

I have been through everything time & time again and cannot see anything wrong.

so to record the audio that is routed to Cubase from the Motif XF I will need to set an audio track.  I have done this but can’t see how to tell it to send the audio here.  The Audio setting for the track is the stereo in & stereo out respectively.

Have you fulfilled those requirements?

I am trying.

You need to know how you are routing the audio to return to the DAW.

As per the set-up through Motif XF using:-

http://www.motifator.com/index.php/support/view/motif_xf_ysfw_setup_mac_with_cubase
and
http://www.motifator.com/index.php/support/view/a_getting_started_guide_motif_xf_editor_vst

Anything you can think of to point me in the right direction would be much appreciated.

Many thanks
Leslie

  [ Ignore ]  

Posted on: March 26, 2013 @ 09:56 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Bad_Mister - 26 March 2013 08:42 AM

You can record MIDI TRACKS if they are routed to a synthesizer (XF) and that synthesizer is setup to RETURN audio to your DAW… via FW.

So I think the answer lies here.....

Motif XF Routing PARTS via Firewire
http://www.motifator.com/index.php/support/view/motif_xf_routing_parts_via_firewire

This is the missing link?

  [ Ignore ]  

Posted on: March 26, 2013 @ 12:55 PM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

It comes down to how you are launching the Editor. If you are launching it with VSTi routing from within Cubase… that is: you go to DEVICES > VST INSTRUMENTS > External > Motif XF VST

If that is what you are doing then you set the audio outputs by going to the Motif XF VST Editor
FILE > VSTi SETUP > Make sure that the OUTPUTS are assigned on this screen.

If you do that then when you are recording MIDI data into Cubase you will see main Cubase Project screen as shown below.

If you do not see the “activity” meter on the AUDIO lane then you have a mistake in routing.

You select the MIDI Track - you must select it in order to communicate with the Motif XF. When you do, and you play you will see the MIDI Activity meter on that MIDI track respond. It is receiving MIDI data from the XF as you play. That track is set to MIDI OUT = MOTIF XF VST… in the Motif XF VST you have set the AUDIO to RETURN to the MAIN LEFT and RIGHT.

If that assignment is made then you will see activity in the AUDIO LANE

Image Attachments
CubaseVSToverview.png
  [ Ignore ]  

Posted on: March 27, 2013 @ 02:17 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Bad_Mister - 26 March 2013 12:55 PM

It comes down to how you are launching the Editor. If you are launching it with VSTi routing from within Cubase… that is: you go to DEVICES > VST INSTRUMENTS > External > Motif XF VST

Yes I am launching the Editor via Cubase.

then you have a mistake in routing.

No audio coming through so definitely a mistake in the audio routing.

I have added some screen shots.

How do I set up the Motif XF?  I have gone to ‘MIXING’ - ‘EDIT’ and changed the FW output to FW1&2;.

Tried to mirror this in Cubase but to no avail. There maybe a clash in ports as I could not set FW for the audio input.

Many thanks
Leslie

Image Attachments
Screen Shot 2013-03-27 4.png
Screen Shot 2013-03-27 1.png
Screen Shot 2013-03-27 2.png
Screen Shot 2013-03-27 3.png
Screen Shot 2013-03-27 5.png
  [ Ignore ]  

Posted on: March 27, 2013 @ 05:51 AM
Nino1119
Total Posts:  8
Joined  03-14-2013
status: Newcomer

hi,

I have a sound problem with motif xf editor when I play so I can hear the sound when it is played and recorded as MIDI, but when I want to export is not any sound. Can you help me?

Screenshots:

Image Attachments
MOTIF.jpg
motif2.jpg
motif3.jpg
  [ Ignore ]  

Posted on: March 27, 2013 @ 07:57 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular
Nino1119 - 27 March 2013 05:51 AM

hi,

I have a sound problem with motif xf editor when I play so I can hear the sound when it is played and recorded as MIDI, but when I want to export is not any sound. Can you help me?


Screenshots:

Hi - am going through the same - here is what Bad_Mister said:-

If the EDITOR is ONLINE that means you have MIDI routing that is fine. But no one has ever heard MIDI so it has nothing to do with hearing anything. So you need to troubleshoot your audio routing.

You have the Motif XF setup as a “VSI” (you mean VSTi). That is a place to start to check your audio routing.

MIDI data recorded to a MIDI track in Cubase is output to the “Motif XF VST MIDI IN” make sure that the MIDI track’s OUT is set to “Motif XF VST Midi In” - if not, set it so that it is.
The MIDI data on the Track is routed to the Motif XF VST editor which is ONLINE with the hardware - so it arrives in the hardware. Now you need to figure out where the audio that responds to this MIDI data is set to go…

Then on the Motif XF Editor click on FILE > VSTi SETUP

Here you can see where the audio goes that the Motif XF generates when it receives the MIDI data via the Motif XF VST.

The audio is considered RETURNING from the Motif XF and being routed somewhere.

I am newbie also and am still struggling to get the audio routing sorted.

I hope this points you in the right direction

  [ Ignore ]  

Posted on: March 27, 2013 @ 12:44 PM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

You are missing some very important settings…

How do I set up the Motif XF?  I have gone to ‘MIXING’ - ‘EDIT’ and changed the FW output to FW1&2;

I’m sorry but that is not what it shows in your screenshots. The screenshot of the Motif XF Editor VST main screen shows all PARTS are routed to “L&R;” _ which is the main LEFT/RIGHT Outputs.

Had you changed the FW OUTPUT to FW1&2;it would appear on the Motif XF Editor VST. And then you would need to activate the OUTPUT on the VST INSTRUMENT rack… See below.

You are also looking in the wrong place for audio connection. Let’s follow the routing of a single channel and I’ll show you how to route it through several different scenarios.

Please start with a new setup and follow this as closely as you can:

Place the Motif XF in SONG mode.
Press [SEQ SETUP]
Press [F3] QUICK
Select QUICK SEQUENCER SETUP #3: Recording on Computer
Press [ENTER]

Launch Cubase
And start a NEW PROJECT - use the “EMPTY” template.

Go to DEVICES > VST INSTRUMENTS > External > Motif XF VST

When the query box appears, it will ask you if you want to create the first MIDI track and have it assigned to this VST… do so. This creates the VST INSTRUMENT folder with one AUDIO LANE and one AUTOMATION LANE, along with the MIDI track assigned to the Motif XF VST… The EDITOR opens and comes ONLINE - if not, bring it ONLINE.  Notice PART 1 is selected and it’s OUTPUT SELECT = L/R

Select the MIDI Track; because LOCAL CONTROL is OFF - you must highlight the MIDI track in order for your Motif XF to be able to communicate with Cubase and for Cubase to send the data back to the Motif XF on the MIDI channel of that Track (CH1) (this process is called “MIDI THRU” the track thru’s the data back to the XF tone engine).

When the MIDI track is selected (highlighted) your key presses travel from the XF via FW-MIDI to the Track which is set so its MIDI OUT = “1-Motif XF VST”

With the MIDI track highlighted RIGHT CLICK and select ADD TRACK > MIDI TRACK, add another MIDI Track. Make sure its OUTPUT is set to “1-Motif XF VST” and that the CHANNEL is 2. In this fashion you can create MIDI tracks, one for each PART you want to record. They should be assigned to “1-Motif XF VST” and each on a different MIDI channel of your Motif XF.

In the Motif XF Editor VST you have the VSTI SETUP set so that the RETURNS are set to return audio to Cubase.
_ The first pair of Outputs from the XF are the MAIN LEFT and the MAIN RIGHT.
_ The second pair of Outputs from the XF are the FW1&2;.
_ The third pair of Outputs from the XF are the FW3&4;.
_ and so on.

In order to activate these OUTPUTS so they arrive in Cubase go to the VST INSTRUMENT rack (the device you used to select the Motif XF VST… on that first slot you will see several icons, among them one that ACTIVATES and DEACTIVATES the OUTPUTS of the Motif XF VST, there are 8 pairs of OUTPUTS;
Main Left/Right
FW 1/2
FW 3/4
FW 5/6
FW 7/8
FW 9/10
FW 11/12
FW 13/14

The main LEFT/RIGHT (First Stereo Pair) is ALWAYS active. If you want to use any of the other FW audio outputs you must ACTIVATE them here, by placing a check mark… see my previous screenshot I show that VST Output ACTIVE/DEACTIVATE drop down

As you play MIDI data the MIDI track will show MIDI activity.
If you have an active output selected the corresponding AUDIO LANE will have activity.

In the lower left corner of the Motif XF VST screen - you should see “REC ON PC” selected
And you should select “with PC” for your FW Monitor Setup.

You will notice that as you select a MIDI Track in Cubase, the Motif XF Editor VST also changes selection… and vice versa, select a PART in the Editor and it automatically selects the track assigned to it in Cubase.

On the EDITOR each PART has a row of parameters - to the right side, please notice the OUTPUT SELECT parameter. This is how the individual PART is set to route its outputs from the XF.

You must ACTIVATE the OUTPUT on the VST INSTRUMENT rack (as mentioned above)… the main LEFT/RIGHT is always active, if you want to use FW1&2;make sure you go to the VST INSTRUMENT Window and where the Motif XF VST is show click on the OUTPUT icon ’[->‘ and activate the second pair of OUTPUTS.

Notice when you activate a second pair of outputs a second AUDIO LANE appears.
Notice when you route a PART of the XF to OUTPUT SELECT = one of the assignable FW outputs, it is removed from the main stereo mix and is removed from the Reverb and Chorus processors (SYSTEM). However, it maintains its assigned INSERT EFFECT if active.

Let us know where you get stuck

  [ Ignore ]  

Posted on: March 28, 2013 @ 03:01 AM
abbaskunk
Total Posts:  16
Joined  02-07-2013
status: Regular

Hi Bad_Mister

That worked perfectly - can’t thank you enough - I feel like I have made some progress today!

Now my next task is to record these 2 tracks I’ve made into a Audio Track. Both tracks are sharing the same Bus route into Cubase at the moment (FW1&2;)

I have created a Audio track and has Stereo In (FW1&2;) set and the standard Stereo Out.  I cannot figure why the audio is not being routed through this Audio Track?

Many thanks for you continued support & patience!
Leslie

  [ Ignore ]  

Posted on: March 28, 2013 @ 03:46 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

I have created a Audio track and has Stereo In (FW1&2;) set and the standard Stereo Out.  I cannot figure why the audio is not being routed through this Audio Track?

Again you have taken a left turn, inexplicably.

Again I ask, you are using the VSTi Routing correct? This means you are using the Editor VST to return audio to Cubase. You already have an AUDIO LANE for the virtual audio return!

So why did you create an Audio Track?

This is what you are NOT understanding. When you are using the Editor VST to route your audio, the audio returns through a virtual Audio track… Which is the AUDIO LANE that I’ve been referring to

When you answer yes to create a MIDI track assigned to the VST Instrument, the setup creates an audio lane assigned to the first pair of audio returns from the XF - if you want to assign Motif XF Parts to FW1/2 in the XF, first set the PART’s OUTPUT SELECT and select “FW1/2”, then You must ACTIVATE the second stereo return from the XF…

Here is how:
Go to Windows on the menu bar and make sure you can see the “VST INSTRUMENT” rack, it has “Motif XF VST” in the first slot.
Click on the OUTPUT icon (looks like a little arrow pointing to the right: ”[->
Place a check mark next to the second stereo pair

Doing so will automatically ADD a second AUDIO LANE to you VST INSTRUMENT folder… This is where you will monitor signal that has been assigned to Motif XF FW1/2.

You do not create an audio track.. This adds an Audio Lane.

Now that you have data returning from you XF via the VST INSTRUMENT AUDIO LANE, when you set the Left and Right markers to EXPORT AUDIO MIXDOWN the virtual audio, heard through that virtual audio track will be MIXDOWN and rendered as a real audio .WAV

By switching to create an AUDIO TRACK (as you say you have), at that point, you are abandoning the VST Instrument Routing.

The difference, VST Instrument routing the audio is monitored only, you must use Export Audio Mixdown to render the audio you hear, to an actual wave.
The setup you make when you go to the VST CONNECTIONS > INPUTS tab, is an entirely different way to setup, it does not use the VST Instrument routing. And you have to commit to one or the other. If you make the connection in one place you disconnect it from the other.

Please go over what I showed you in the previous post, try and understand what the VST INSTRUMENT thing about Activating Outputs is about. Activate ALL THE OUTPUTS.... See how that changes your Track view Window in Cubase. Now in the Motif XF Editor VST take Part 1 and reassign the OUTPUT SELECT parameter to FW3/4, play the keyboard, see where the audio is now returning. Now reassign Part 1 to OUTPUT SELECT = FW5/6, play the keyboard see where the audio is now returning.

Until you see this I think you are doomed to some confusion.

Instead of using the VST CONNECTION > INPUT screen to assign outputs to Cubase inputs, you have opted to make the routing decisions within the Cubase VST INSTRUMENT. When using the VST Instrument to make the routing decisions you assign them as I have described above.  Don’t mix them up.

  [ Ignore ]  


Page 1 of 2