mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "USB Wifi Device Problem"

     
Posted on: December 17, 2011 @ 10:53 PM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru

I just got an Edimax EW-7811Un USB WiFi device which I tried to use with my xf7. Didn’t work. When I set the xf7’s network option to “infrastructure”, all I got was “wireless device disabled”. But the device works fine when I plug it into my PC.

I know it’s not on the approved list, but the Edimax EW-7711UAn is. Is the Motif xf that picky about USB WiFi devices?

I currently have a Buffalo WLI-UC-GNM on order, which is on the list. I’m hoping that’ll work better, but I’m really curious why the Edimax didn’t work.

I’m hoping that it’s not an indication that something’s wrong with my xf7. The USB port on it works fine with flash drives, which is a hopeful sign.

Any wisdom about what the story is with all of this (a link to a document would be fine) would be gratefully appreciated.

  [ Ignore ]  

Posted on: December 18, 2011 @ 07:19 AM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

I just got an Edimax EW-7811Un USB WiFi device which I tried to use with my xf7. Didn’t work. When I set the xf7’s network option to “infrastructure”, all I got was “wireless device disabled”. But the device works fine when I plug it into my PC.

You set the WIRELESS NETWORK option to “infrastructure” - but you don’t mention to what you were attempting to connect. Perhaps your wireless device is actually disabled.

If a device is not on the compatibility list, it simply means it has not been tested. Yamaha has no way of testing every USB WiFi device on the market. The ones that were tested as OK will make a list. Certainly no one has a list of incompatible devices and reasons as to why (that I know of)

But before you conclude the device is not working, tell us what you were attempting to connect to, many times home networks are so security tight, you as administrator cannot even get in.
:-)

My recommendations:

Setup your NETWORK parameters in the XF
[UTILITY] > [F5] CONTROL > [SF2] MIDI > set MIDI IN/OUT = NETWORK
Press [F1] GENERAL > [SF3] NETWORK
Setup your parameters, STORE them (very important) then REBOOT!

Return to the WIRELESS NETWORK option, hit ENTER and determine how and to what you want to connect wirelessly…

let us know.

  [ Ignore ]  

Posted on: December 19, 2011 @ 08:05 PM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru

Hi, Bad_Mister, thanks for the quick response.

I would’ve been more specific, but I had no idea you could send MIDI commands via a WiFi network. I was trying to do something different and (I would suspect) simpler: store a file (e.g. data, .WAV) from the xf7 directly to my PC via WiFi. I figured that the way to do this was to connect my xf7 to my wireless home network. I read somewhere that you need to do this via ‘infrastructure’ mode.

So here’s what I did:

[Utility]
[SF3] Network
set ‘Device’ to ‘wireless’
select/hilite the ‘Wireless Setting’ button
[Enter]
set ‘Configuration’ to ‘infrastructure’

(at this point, I see ‘Wireless device disabled’ in the lower panel)

[SF5] Add
I then enter my home network’s SSID and Passphrase. I set ‘Security’ to WPA/WPA2, which is what my router is set to support.
[Enter]

There follows a long pause with a rotating graphic and the word ‘Executing’. But when it’s done, the only thing I see in the lower panel is still ‘Wireless device disabled’.

One other piece of information: when I plug the wireless device into my PC, it shows a flashing blue light. When I plug it into the xf7, there’s no blue light at all. The device is a tiny thing on the end of one of those big rectangular USB connectors (type A). So I plug it into that shape plug in the xf7. I’ve noticed that there are 2 USB connectors on the xf7: the rectangular one and a smaller D-shaped one (type B). They are labeled (Type A) ‘TO DEVICE’ and (Type B) ‘TO HOST’. Am I plugging the wireless device into the right USB plug? That might explain why there’s no flashing blue light when it’s plugged into the xf7.

My router is a Netgear Wireless-N 150 (model WNR1000). It’s set to: WPA-PSK [TKIP] + WPA2-PSK [AES]. I have MAC address filtering turned on, and I’ve added the MAC address of the wireless device (etched in tiny little letters on its USB plug). I also added the MAC address of the xf7, which probably didn’t accomplish anything, but probably doesn’t hurt.

I’m totally open to the idea that I’ve wandered off in the wrong direction trying to do something impossible. But if it were possible to do, it’d be cool, and much more convenient than stringing an Ethernet cable across my office.

  [ Ignore ]  

Posted on: December 19, 2011 @ 10:33 PM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

I’d say that the fact that the light is not flashing could be an indication that it is not working in the Motif XF. It is impossible to plug it into the wrong jack (that’s why they make them different). :-) It should be plugged into the “TO DEVICE” jack.

How is the device connected to the Motif XF? Is it conneted through a hub? The fact that it does not light up, says to me it is not getting powered. If you have too many devices plugged into a hub, you may not have enough bus power to power all of your devices?

We are not sure where you are getting instructions that you are following as to what to filter, or why you are filtering the MAC Address ? ? ? so we cannot comment on this.

  [ Ignore ]  

Posted on: December 20, 2011 @ 04:24 PM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru
Bad_Mister - 19 December 2011 10:33 PM

I’d say that the fact that the light is not flashing could be an indication that it is not working in the Motif XF. It is impossible to plug it into the wrong jack (that’s why they make them different). :-) It should be plugged into the “TO DEVICE” jack.

‘TO DEVICE’ is what I was using. Sounds like I need to wait for the Buffalo wireless device that is on the approved list.

Bad_Mister - 19 December 2011 10:33 PM

How is the device connected to the Motif XF? Is it conneted through a hub? The fact that it does not light up, says to me it is not getting powered. If you have too many devices plugged into a hub, you may not have enough bus power to power all of your devices?

I tried it both with and without a hub. No blue light on the wireless device either way. Two flash drives and a computer keyboard work fine together connected simultaneously to the xf7 via the hub.

Bad_Mister - 19 December 2011 10:33 PM

We are not sure where you are getting instructions that you are following as to what to filter, or why you are filtering the MAC Address ? ? ? so we cannot comment on this.

I have the router set to do MAC address filtering. It will only communicate with devices I own. The router has a list of their MAC addresses, entered by me.

It’s a security thing. All the wireless routers I’ve ever seen have this capability.

  [ Ignore ]  

Posted on: December 21, 2011 @ 02:09 PM
MarPabl
Avatar
Total Posts:  560
Joined  09-08-2011
status: Guru

Set the type of WiFi network to Ad-Hoc instead of infrastructure.
Maybe this will enable the device and after that, you’ll be able to set your infrastructure WiFi network.

  [ Ignore ]  

Posted on: December 23, 2011 @ 06:53 PM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru

Turns out that the Edimax 7811-Un is not compatible with my xf7. I just got a Buffalo WLI-UC-GNM and it all works fine.

“Infrastructure” is apparently the right way to hook up via a wireless router. It’s the mode that asks all the right questions and gives you a way to provide the answers.

“Ad-hoc” mode, for instance only supports WEP WiFi encryption. My WiFi network is set up with WPA. Infrastructure mode gives me the WPA option, and provides a place to type in the encryption passphrase.

  [ Ignore ]  

Posted on: March 20, 2012 @ 12:09 AM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru

Lately when I try to connect from my xf7 to my wireless network, it takes me a few tries until I can establish the connection.

What happens before that is that I hit the Mount button, and when the “gathering information from the network” message goes away, the list of devices to connect to is empty.

It’d be nice if it worked reliably on the first try. Any ideas?

Thanks…

  [ Ignore ]  

Posted on: March 20, 2012 @ 12:20 AM
VikasSharma
Avatar
Total Posts:  1523
Joined  10-05-2010
status: Guru
Michael Trigoboff - 20 March 2012 12:09 AM

Lately when I try to connect from my xf7 to my wireless network, it takes me a few tries until I can establish the connection.
...
It’d be nice if it worked reliably on the first try. Any ideas?

Are you on OS v1.30? See the following threads:

http://www.motifator.com/index.php/forum/viewthread/458753/
http://www.motifator.com/index.php/forum/viewthread/458853/

  [ Ignore ]  

Posted on: March 20, 2012 @ 10:37 AM
Michael Trigoboff
Avatar
Total Posts:  618
Joined  09-05-2011
status: Guru

Thanks for the links to those threads. It hadn’t occurred to me that v1.30 could be the problem. But I think I started noticing the problem around the time I upgraded to v1.30. I need to use the wireless connection maybe once a week, so I can’t pin it down exactly.

I am using the approved Buffalo adapter.

One possibility that I still need to check is that I currently have my Wifi network running at b/g speeds because my Nook Simple Touch e-reader can’t connect when the network is running faster. I’m going to speed up the network and see if that helps.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ System Exclusive Messages
Next Topic:

    What to check to receive midi song select ››