mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Motif on USB and Cakewalk with an echo."

     
Posted on: March 10, 2009 @ 04:25 PM
LeTutankhamen
Total Posts:  23
Joined  12-16-2008
status: Regular

I have decided to plug my Motif Classic via USB instead of MIDI and running Cakewalk. I can actually record on any track, but as I play, there is an echo. As I press a one note, I hear two of the same notes. When listening, it sounds OK without the echo. Any clues?
Greatly appreciate.
The site looks different.

  [ Ignore ]  

Posted on: March 10, 2009 @ 09:54 PM
BradWeber
Avatar
Total Posts:  14986
Joined  07-26-2002
status: Legend

This sounds like you might have a MIDI loop in your setup. If you have not turned local control off on the Motif when you are recording a sequence to Cakewalk (Pro-Audio, Sonar???), the notes that you play on the Motif’s keyboard will be sent twice to the Motif’s tone generator - once directly from the keyboard to the tone generator and also echoed from Cakewalk back to the Moitif via the virtual MIDI OUT in the USB connection from your computer.

The normal fix for this problem is to turn off local control on the Motif by setting the LocalCtrl parameter in the [UTILITY]-->[F5] MIDI-->[SF2] SWITCH dialog to off. This will disconnect the Motif’s keyboard from its tone generator and therefore the tone generator will only receive the notes played once - echoed from Cakewalk. If you take this approach, don’t forget to turn local control back on when you exit Cakewalk as the Motif will not sound without either local control on or Cakewalk (or some other program such as MIDI-OX) echoing the notes back from the keyboard to the tone generator.

Regards,

Brad Weber

  [ Ignore ]  

Posted on: March 14, 2009 @ 05:53 PM
LeTutankhamen
Total Posts:  23
Joined  12-16-2008
status: Regular

It worked, thanks. I followed the directions and had to turn off “Localctrl” off but there is a delay. Can anything be done?

  [ Ignore ]  

Posted on: March 14, 2009 @ 07:07 PM
Bad_Mister
Avatar
Total Posts:  36648
Joined  07-30-2002
status: Moderator

The Yamaha USB-MIDI driver should give you great performance in terms of latency. If you are not getting that performance we would need to know a bit more about your setup and your Computer.

If you can notice the delay this is either not enough CPU power or a bad setting in your setup of your DAW.

  [ Ignore ]  

Posted on: March 15, 2009 @ 04:56 AM
LeTutankhamen
Total Posts:  23
Joined  12-16-2008
status: Regular

Thanks for responding. I am running Cakewalk Pro Audio on a 1.20GHs/1.21 GB of RAM/OS XP prof SP2. Any of the samples plays well. As soon as I put my finger to play, there is a delay. Assign Instrument is Motif6-1. There is also Motif6-2,3,4. I am guessing that Motif 6-1 takes priority. Under “Define instrument”: Motif 6-Pach Names for Banks =1..128. The note names start like so 0=1,1=2, instead of 0..127. I would think that 0= Grand Piano or something recognizable. When I was setting my M1 Korg some years ago, I had to list each and every name so that they appeared as I chose my channels and matching Banks.
Do I have to do the same for the Motif? If so, would that be the list of instruments under Pattern, Performance, Voice or Master? Please see the attachment below to give you an idea of what I am seeing.
Thanks!

File Attachments
Bank name.doc  (File Size: 163KB - Downloads: 337)
  [ Ignore ]