mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Prevent (drum) arps from retriggering in Performance mode"

     
Posted on: October 19, 2019 @ 10:13 AM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

Hi there,

Finally I’m getting there with my newest Motif, the great XF! Combining all my favorit voices from my good old XS into the user banks, more and more happy with the Flashboard that keeps the samples there!  :  )

Now I start combining these voices in Performance mode. In performances that are already in the machine, a drum arp is not retriggered when playing the performance (‘hold’ is set to ‘on’).
But when I make a performance from scratch and add a drum voice, and a drum arp, set ‘hold’ to ‘on’ and then play ... the drum arp is retriggered when I’m playing the performance (and when not perfectly in sync, you hear the drum arp stop and start ...).

I compared my performance (drum voice settings) to that of the ‘good working’ performances but couldn’t find a cause (drum Arp, hold set to ‘on’, range of keys: all the keybed ...). Hope there is this one magic parameter that gets things right ....

Must be something I’m missing, maybe explained already, but would be of great help getting this right. Thanks for advice (or a links to an article where this is adressed...)

Kind regards, Michiel

  [ Ignore ]  

Posted on: October 19, 2019 @ 10:25 AM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

Think I found the answer here on the forum .... the only thing is ... it seems to work but ... playing the performance, the keyboard still triggers the separate drum voices along the keybed. I have a simple performance with 2 parts/voices: first voice is a vintage arp sound, second part/voice is a drum voice. So both play an arpeggiator pattern. Drum arps won’t stop. But playing it does give me a lot of unwanted drum sounds ‘extra’ .... Did I miss a paramter ... ?

Arp Play only
The parameter “ARP Play Only” is available only in Performance and Mixing Parts ([F1] VOICE > [SF1] VOICE - top right of the display). If the parameter is set to ON, the relevant Part only plays back the MIDI note events from the Arpeggio playback. This is especially useful for Drum Arpeggios in Performances. If the Arpeggiator is off, usually single drum sounds are played when you play on the keyboard. Which is usually not desirable when you want to play the instrument Parts without Arpeggiator. If “ARP Play Only” is set to ON in the drum Part, it won‘t produce any sound when the Arpeggiator is off.

  [ Ignore ]  

Posted on: October 19, 2019 @ 10:35 AM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

The performances that have a drum arp going on and the keybed is not triggering drum sounds (this is what I want in my performance) ..... they have the “arp play only” set to .......... “off” ...

Question remains ... how do I program the drums part, playing an ‘Arp’ with hold set to ‘on’ but no extra drum sounds heard when playing the keyboard ... ?

Help would be appreciatied! (very rewarding, but a bit of a learning curve here ... :  )

Kind regards, Michiel

  [ Ignore ]  

Posted on: October 19, 2019 @ 11:11 AM
5pinDIN
Avatar
Total Posts:  11023
Joined  09-16-2010
status: Legend
Michiel D - 19 October 2019 10:35 AM

The performances that have a drum arp going on and the keybed is not triggering drum sounds (this is what I want in my performance) ..... they have the “arp play only” set to .......... “off” ...

Please give examples of such factory Performances.

  [ Ignore ]  

Posted on: October 19, 2019 @ 11:51 PM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

I’ll give 2 random exeamples

Funky Finger (user 1, perf 28)
- drum voice PDR 2
- Note limit: c-2 - G8
- arp limit: c-2 - G8
- parameter with voice: off
- arp play only: off

Organ Cruise (user 1, perf 31)
- drum voice: pdr 39
- all other parameters: same as above

  [ Ignore ]  

Posted on: October 20, 2019 @ 02:56 AM
5pinDIN
Avatar
Total Posts:  11023
Joined  09-16-2010
status: Legend
Michiel D - 19 October 2019 11:51 PM

I’ll give 2 random exeamples

Funky Finger (user 1, perf 28)
- drum voice PDR 2
- Note limit: c-2 - G8
- arp limit: c-2 - G8
- parameter with voice: off
- arp play only: off

Organ Cruise (user 1, perf 31)
- drum voice: pdr 39
- all other parameters: same as above

Sorry, but for Part 1, where the drum kit is found in both of the Performance examples, ARP Play Only is on.
See http://www.motifator.com/index.php/forum/index.php/viewthread/481497/

By the way, those two Performances are in USER 2 with an XF that’s factory reset. They’re in USER 1 on an XS - or if an XS “All” file is loaded to an XF, but doing that loses the unique Performances (and Voices) found in USER 1 of a factory set XF, and initializes all the USER 4 locations where the USER 3 bank from the XS would normally be. If you’re loading XS data to an XF, and don’t want to lose the XF-exclusive material, for Voices I suggest using Load Type “1 bank voice”, rather than “all”. Performances can be loaded individually.

  [ Ignore ]  

Posted on: October 20, 2019 @ 03:25 AM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

Thanks for looking into this case ... :  ) Indeed the performances are not the XF factory reset performances.
Fortunately I made a backup of the XF so will put the original performances back.
Question remains, when initialising a performance, than make your own performance, how to prevent the arp of the drums retriggering playing the keybed. Now everytime I hit the keys, drum arp restarts with a base/crash (and a rhytmic hickup).... Will check out if the hints and tips do have the wanted effect when working from the XF factory set ... I let you know!

  [ Ignore ]  

Posted on: October 20, 2019 @ 04:18 AM
5pinDIN
Avatar
Total Posts:  11023
Joined  09-16-2010
status: Legend
Michiel D - 20 October 2019 03:25 AM

Question remains, when initialising a performance, than make your own performance, how to prevent the arp of the drums retriggering playing the keybed. Now everytime I hit the keys, drum arp restarts with a base/crash (and a rhytmic hickup).... Will check out if the hints and tips do have the wanted effect when working from the XF factory set ... I let you know!

It seems you are describing an issue with the Accent Velocity Threshold setting. Try turning it off.

See http://www.motifator.com/index.php/forum/viewthread/456198/

  [ Ignore ]  

Posted on: October 20, 2019 @ 05:50 AM
Michiel D
Total Posts:  175
Joined  11-16-2009
status: Pro

YES ..!! This did the trick, it was (by default?) set tot 64 ... now it works like a charm :  )

  [ Ignore ]  

Posted on: October 20, 2019 @ 07:21 AM
5pinDIN
Avatar
Total Posts:  11023
Joined  09-16-2010
status: Legend
Michiel D - 20 October 2019 05:50 AM

YES ..!! This did the trick, it was (by default?) set tot 64 ... now it works like a charm :  )

Indeed, 64 is the default value. I’m glad that the issue is now resolved.

  [ Ignore ]